Requirements for using the website editor

The browser you are currently using is not supported by the website editor. Please read the information below to find out how to update your browser to the latest version.

The website editor runs in your web browser. Most common browsers are supported.

Chrome

Chrome automatically updates when a new version is released, or you can check for updates manually. The website editor always supports the latest version, but is not tested in older versions.

Firefox

Firefox automatically updates when a new version is released, or you can check for updates manually. The website editor always supports the latest version, but is not tested in older versions.

Internet Explorer

Microsoft released the final version of Internet Explorer in 2013 and launched its replacement, Edge, in 2015. The website editor no longer supports Internet Explorer, and to edit your site you will need to upgrade to Edge, or use one of our other supported browsers.

Please note that this only affects the website editor: your visitors will be able to continue using Internet Explorer to view your website.

Microsoft Edge

If Windows Update is enabled, Microsoft Edge automatically updates when a new version is released. The website editor always supports the latest versions, but is not tested in older versions.

Safari

If Software Update is enabled, Safari automatically updates when a new version is released. The website editor always supports the latest version, but is not tested in older versions.